Ford vs Chevy
Oil Pressure Problems - Printable Version

+- Ford vs Chevy (https://fordvschevy.com)
+-- Forum: FvC Technical (https://fordvschevy.com/forum-5.html)
+--- Forum: General Tech (https://fordvschevy.com/forum-16.html)
+--- Thread: Oil Pressure Problems (/thread-7755.html)



Oil Pressure Problems - Lux - 06-09-2007

88 Mustang - 4cylinder

Fresh oil + Filter.

When initially started, fantastic oil pressure, once warmed up oil pressure goes to almost Zero @ idle but oil pressure is OK as long as RPMS are up.

After being driven for about 20 minutes, oil pressure keeps dropping, increased RPM helps boost oil pressure but less and less. About a 1/2 hour after being warmed up, oil pressure becomes non existant @ idle and VERY LOW, no matter what rpm.

The motor sounds and runs fine.

Any ideas?

I'm thinking oil pump and/or screen might be clogged...i dont think its the gauge.

TIA


Oil Pressure Problems - SVT Town Car - 06-09-2007

I'd say oil pump/screen - but for shits n' giggles, how many miles are on it?

I've had quite a few windstars w/ the 3.8 have this very problem - dropped the oil pan - and NOTHING but crud n' shit on the inlet screen...(pump was ok)


Oil Pressure Problems - Lux - 06-09-2007

like 80,000

it hasnt been driven for 7 years...so i figured it was just viscosity break down, until i changed the oil and it had the same problem.


Oil Pressure Problems - 78oldscutlass455 - 06-09-2007

Its probably parrafin wax and carbon deposits being sucked off the bottom of the pan (as SVT said). Drop your pan and check for that. It also wouldnt hurt to pull a couple of main and rod caps to check your bearings.


Oil Pressure Problems - Charlie - 06-09-2007

I'd recommend that you do not trust the factory gage. Check to make sure of the oil pressure before you do anything else!!!!